Browser issue/question

Wiis, PlayStations, iPads, blogging platforms, Facebook and anything else worthy of buzz in the digital world.
narcoleptish
Forum God/Goddess
Posts: 4423
Joined: Mon Mar 14, 2005 12:35 am

Browser issue/question

Postby narcoleptish » Fri Feb 26, 2016 1:17 pm

I'm just throwing this on here because I haven't had much luck sorting through the 4-6 year old answers that typically come up first on my searches.

Recently switched to a macbook air that had been "cleaned" or whatever, 4-5 years old. I installed newest Firefox browser and within a couple of weeks it's painfully slow with colorwheels all the time. With 3 tabs open, 2 gmail accounts and this site, the activity monitor shows firefox jumping around everywhere from 8% to 87% cpu. The activity monitor is the only other thing that even registers.

Firefox on my old macbook got very slow and often required a force quit, but it happened very gradually over time. I block pop-ups and have erased all cookies. I've never looked at Madison.com or Salon.com on this computer, which notoriously clogged up my old one. No porn. I really only look at a handful of sites other than email. We have Charter.

Advice?
Run one of the "repair" sequences?
Switch to Chrome?
Take some downers so slow seems normal?

Thanks

jman111
Forum God/Goddess
Posts: 4659
Joined: Wed Aug 12, 2009 12:43 pm
Location: Dane County
Contact:

Re: Browser issue/question

Postby jman111 » Fri Feb 26, 2016 1:23 pm

Friday afternoon...I'd go with Option C.

Plenty of time for real fixes later.

rabble
Forum God/Goddess
Posts: 9601
Joined: Tue Jun 10, 2008 7:50 pm

Re: Browser issue/question

Postby rabble » Fri Feb 26, 2016 1:28 pm

Firefox was my browser of choice for a long time and I still use it when I'm troubleshooting website problems but a while ago we noticed every update just made it slower and more of a memory hog. After a while it had glommed onto so much memory that the whole computer lugged down.

We went to Chrome. It's very similar. We got used to the little differences.

Roy
Forum God/Goddess
Posts: 5896
Joined: Sun Jul 17, 2005 11:31 pm

Re: Browser issue/question

Postby Roy » Fri Feb 26, 2016 1:45 pm

narcoleptish wrote:Firefox browser and within a couple of weeks it's painfully slow with colorwheels all the time.

The problem of slowdown after a few weeks use is inherent to Firefox. I use Pale Moon which is a Firefox open source spinoff that is optimized for Windows and alleviates the slowdown problem. Unfortunately they don't have a MAC version that I am aware of. They probably have it in development though.

Shorty
Forum God/Goddess
Posts: 3362
Joined: Mon Jun 02, 2003 12:53 pm

Re: Browser issue/question

Postby Shorty » Fri Feb 26, 2016 3:17 pm

Sorry I can't help with that but here is advice. If you use a laptop you may want to consider getting a Defender shield to protect you.

https://www.defendershield.com/shop/def ... aQod8D8IqA

Health Risks
Direct exposure to laptop ELF radiation, RF radiation and heat radiation emissions can cause a variety health risks such as:

-Fertility problems in men and women
-DNA fragmentation (irreversible changes to the genetic code)
-Toasted Skin Syndrome (Erythema ab igne), burns and rashes
-Other serious health concerns

Just place the DefenderPad® Laptop Radiation & Heat Shield between your laptop and your body to protect yourself from a broad spectrum of potentially harmful radiation and heat emissions.

narcoleptish
Forum God/Goddess
Posts: 4423
Joined: Mon Mar 14, 2005 12:35 am

Re: Browser issue/question

Postby narcoleptish » Fri Feb 26, 2016 4:13 pm

To me, fertility itself is (was) the problem. But I took care of that.

Contrary to many opinions, NObody knows what the long-term effects of all our devices will be, because the long-term isn't here yet, and there's waaay too much money to be made for any suspected risks to be acknowledged.

Back on topic, looks like I may have to try Chrome.

Thanks for the input.

fennel
Forum God/Goddess
Posts: 4818
Joined: Thu Sep 28, 2006 4:24 pm
Location: Inside the Green Zone, Madison

Re: Browser issue/question

Postby fennel » Fri Feb 26, 2016 4:25 pm

I'm pretty happy with Safari 9.0.3. (It does have an issue with the address bar.) Chrome may have some performance advantages, but I can't help but think of it as spyware. When I had it, some process kept calling home to its overlords. That seemed creepy, but the more pressing problem was that it snarled my automatic backups.

Ducatista
Forum God/Goddess
Posts: 5231
Joined: Fri Mar 05, 2004 11:31 am
Location: 53703

Re: Browser issue/question

Postby Ducatista » Fri Feb 26, 2016 4:35 pm

Hmmm. I'm on an early 2015 Air, 2.2GHz i7, 8 GB RAM, and Firefox is my default browser. Haven't had any boggy issues with that setup. Don't remember issues with my last Air, either (early 2010 model).

fennel
Forum God/Goddess
Posts: 4818
Joined: Thu Sep 28, 2006 4:24 pm
Location: Inside the Green Zone, Madison

Re: Browser issue/question

Postby fennel » Fri Feb 26, 2016 4:59 pm

Apropos of nothing, a friend was just given a spanking new MacBook Air by her employer, as an acknowledgement of 15 years of service. Damn.

Madsci
Forum God/Goddess
Posts: 1467
Joined: Tue Feb 06, 2007 6:47 pm

Re: Browser issue/question

Postby Madsci » Fri Feb 26, 2016 7:57 pm

narcoleptish wrote:I'm just throwing this on here because I haven't had much luck sorting through the 4-6 year old answers that typically come up first on my searches.

Recently switched to a macbook air that had been "cleaned" or whatever, 4-5 years old. I installed newest Firefox browser and within a couple of weeks it's painfully slow with colorwheels all the time. With 3 tabs open, 2 gmail accounts and this site, the activity monitor shows firefox jumping around everywhere from 8% to 87% cpu. The activity monitor is the only other thing that even registers.

Firefox on my old macbook got very slow and often required a force quit, but it happened very gradually over time. I block pop-ups and have erased all cookies. I've never looked at Madison.com or Salon.com on this computer, which notoriously clogged up my old one. No porn. I really only look at a handful of sites other than email. We have Charter.

Advice?
Run one of the "repair" sequences?
Switch to Chrome?
Take some downers so slow seems normal?

Thanks

I do believe I have the same computer and had the same problem.
My fix was to go into Firefox preferences and under Startup un-select the box "always check if Firefox default browser". It worked for me, good luck to you.

narcoleptish
Forum God/Goddess
Posts: 4423
Joined: Mon Mar 14, 2005 12:35 am

Re: Browser issue/question

Postby narcoleptish » Sun Feb 28, 2016 6:04 pm

fennel wrote:I'm pretty happy with Safari 9.0.3.


I switched to this after you posted and so far, sooo much better. Way faster than I ever remember Firefox being. Used Safari years ago and can't remember when or why I switched.

Thanks fennel

narcoleptish
Forum God/Goddess
Posts: 4423
Joined: Mon Mar 14, 2005 12:35 am

Re: Browser issue/question

Postby narcoleptish » Thu Apr 07, 2016 8:10 am

Hey fennel (or anyone using safari 9.0.3) - After a month+ of super fast & smooth browsing with el capitan, it has suddenly slowed waay down on loading pages. But not always, it's sporadic but slow more often than not. The little blue line under the address bar that measures page loading will shoot out half an inch and then just freeze there. Sometimes it takes 10-20 seconds, sometimes they just don't load.

Online searches (when they load) show lots of references to this but I get so lost in the mac forum tech talk. I tried the basics of restarting everything, modem included. Do I really need to get into running repair functions, etc after one fucking month?

Roy
Forum God/Goddess
Posts: 5896
Joined: Sun Jul 17, 2005 11:31 pm

Re: Browser issue/question

Postby Roy » Thu Apr 07, 2016 8:43 am

Try clearing your cache. It is like taking the garbage out. If you don't do it regular, it builds up. If you visit a lot of sites it may also help to clear cookies, although then you have to login again everywhere.

fennel
Forum God/Goddess
Posts: 4818
Joined: Thu Sep 28, 2006 4:24 pm
Location: Inside the Green Zone, Madison

Re: Browser issue/question

Postby fennel » Thu Apr 07, 2016 8:53 am

Yeah, I routinely purge all cookies and empty the cache. Often several times an hour. It's really just habit. I've also set up a shortcut to disable javascript from time to time. Some poorly designed sites require it, but not most.

And adblock plus. Basically, you want to avoid loading unnecessary crap, especially ads which can come from Bob knows where and can contain all kinds of evil or processor-intensive schmutz.

narcoleptish
Forum God/Goddess
Posts: 4423
Joined: Mon Mar 14, 2005 12:35 am

Re: Browser issue/question

Postby narcoleptish » Thu Apr 07, 2016 9:02 am

Thanks you two.

I do semi-routinely clear cookies. I just cleared cache and still have the problem. Craigslist is my default test because it generally loads immediately, being devoid of outside ads and pop-ups... but it froze there too. It seems like the initial page load is the bigger issue. Once I'm on a site it is better. Not like before, but better.

The biggest user on activity monitor is activity monitor.


Return to “Technology & Video Games”

Who is online

Users browsing this forum: No registered users and 1 guest